summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-20 14:31:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-20 16:21:45 +0100
commitb4469ce95e32c4a32800b43d6ba489eea0dfb2bb (patch)
treec71ebf4e60d59195d8815938f236d56593cb0a52 /dev-ros/rosconsole/rosconsole-1.12.7.ebuild
parentdev-ros/rosbag_storage: Bump to 1.12.7. (diff)
downloadgentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.tar.gz
gentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.tar.bz2
gentoo-b4469ce95e32c4a32800b43d6ba489eea0dfb2bb.zip
dev-ros/rosconsole: Bump to 1.12.7.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-1.12.7.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-1.12.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/rosconsole-1.12.7.ebuild b/dev-ros/rosconsole/rosconsole-1.12.7.ebuild
new file mode 100644
index 000000000000..b26b7ce325bc
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.12.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}