summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:39:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:41 +0100
commit2dc0c87ade36c44779dd9ea81f551e0409708d94 (patch)
tree1eed5491c088a38e9436d42c7b6ca482be8d9eba /dev-ros/rosconsole/rosconsole-1.13.5.ebuild
parentdev-ros/rosbag_storage: Bump to 1.13.5. (diff)
downloadgentoo-2dc0c87ade36c44779dd9ea81f551e0409708d94.tar.gz
gentoo-2dc0c87ade36c44779dd9ea81f551e0409708d94.tar.bz2
gentoo-2dc0c87ade36c44779dd9ea81f551e0409708d94.zip
dev-ros/rosconsole: Bump to 1.13.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-1.13.5.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-1.13.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/rosconsole-1.13.5.ebuild b/dev-ros/rosconsole/rosconsole-1.13.5.ebuild
new file mode 100644
index 000000000000..f6a79d44be2f
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.13.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}