summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:14:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:55:36 +0100
commit009146365f76fc06f109bf2dd337377c85196ebc (patch)
tree61ef5e6a82f175cbb5b2a59dc674a79e7aa728b6 /dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild
parentros-meta/roscpp_core: Bump to 0.6.0. (diff)
downloadgentoo-009146365f76fc06f109bf2dd337377c85196ebc.tar.gz
gentoo-009146365f76fc06f109bf2dd337377c85196ebc.tar.bz2
gentoo-009146365f76fc06f109bf2dd337377c85196ebc.zip
dev-ros/roscpp_tutorials: Bump to 0.7.0.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild')
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild
new file mode 100644
index 000000000000..5313d6fef602
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"