summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 11:02:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 11:21:12 +0200
commit1a850fdc607730b23b3919c73199c8bc2c6a5273 (patch)
treeef921b4d6c047409d91aa10ec2101ee85178166d /dev-ros/roscreate/roscreate-1.13.2.ebuild
parentdev-ros/rosclean: Bump to 1.13.2. (diff)
downloadgentoo-1a850fdc607730b23b3919c73199c8bc2c6a5273.tar.gz
gentoo-1a850fdc607730b23b3919c73199c8bc2c6a5273.tar.bz2
gentoo-1a850fdc607730b23b3919c73199c8bc2c6a5273.zip
dev-ros/roscreate: Bump to 1.13.2.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/roscreate/roscreate-1.13.2.ebuild')
-rw-r--r--dev-ros/roscreate/roscreate-1.13.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.13.2.ebuild b/dev-ros/roscreate/roscreate-1.13.2.ebuild
new file mode 100644
index 000000000000..a7bfd5f62c6a
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.13.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"