summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 13:58:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:21:03 +0200
commit6429686c8e447d97bf44e2a89509ca61d339dcda (patch)
tree6e342aee7560670aeff55e4b891ad2136e33b4e0 /dev-ros/roscreate/roscreate-1.15.6.ebuild
parentdev-ros/rosclean: Bump to 1.15.6. (diff)
downloadgentoo-6429686c8e447d97bf44e2a89509ca61d339dcda.tar.gz
gentoo-6429686c8e447d97bf44e2a89509ca61d339dcda.tar.bz2
gentoo-6429686c8e447d97bf44e2a89509ca61d339dcda.zip
dev-ros/roscreate: Bump to 1.15.6.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/roscreate/roscreate-1.15.6.ebuild')
-rw-r--r--dev-ros/roscreate/roscreate-1.15.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.15.6.ebuild b/dev-ros/roscreate/roscreate-1.15.6.ebuild
new file mode 100644
index 000000000000..34cd94cd1e66
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.15.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
+"