summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-26 19:26:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-26 19:29:30 +0200
commit0633d0023040df5707ae56b38d25d3f0cef22d67 (patch)
tree1e11c03161db35352a90d8bafc1034cead3cb6ad /dev-ros/rosdiagnostic
parentdev-ros/test_diagnostic_aggregator: forward port gcc6 patch (diff)
downloadgentoo-0633d0023040df5707ae56b38d25d3f0cef22d67.tar.gz
gentoo-0633d0023040df5707ae56b38d25d3f0cef22d67.tar.bz2
gentoo-0633d0023040df5707ae56b38d25d3f0cef22d67.zip
dev-ros/rosdiagnostic: initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rosdiagnostic')
-rw-r--r--dev-ros/rosdiagnostic/Manifest1
-rw-r--r--dev-ros/rosdiagnostic/metadata.xml11
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-1.9.0.ebuild21
-rw-r--r--dev-ros/rosdiagnostic/rosdiagnostic-9999.ebuild21
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/rosdiagnostic/Manifest b/dev-ros/rosdiagnostic/Manifest
new file mode 100644
index 000000000000..c0da37d2e259
--- /dev/null
+++ b/dev-ros/rosdiagnostic/Manifest
@@ -0,0 +1 @@
+DIST diagnostics-1.9.0.tar.gz 528593 SHA256 9cd6f439e55195b482b9702369514dde25865a256f3059eb7f475da7ddd483d6 SHA512 98086feb84939108a959b36a3f59a7c52b4413ceb57d5c3c393db98dfad4c5f1572f584248293502a27619db706a585ebe0cb98c4af0b8681d6d78be0e1c022c WHIRLPOOL 2d54da752f0cf194082d7e2cab863e744bda0b4b4a01e618c0d57f8c3bf8991441682c3554a2957265bbe3f247dccabb4f9a17852b7a4b26257fa68120b28e74
diff --git a/dev-ros/rosdiagnostic/metadata.xml b/dev-ros/rosdiagnostic/metadata.xml
new file mode 100644
index 000000000000..6cc2de656785
--- /dev/null
+++ b/dev-ros/rosdiagnostic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/diagnostics</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-1.9.0.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.0.ebuild
new file mode 100644
index 000000000000..c186f88cf03c
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-1.9.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
diff --git a/dev-ros/rosdiagnostic/rosdiagnostic-9999.ebuild b/dev-ros/rosdiagnostic/rosdiagnostic-9999.ebuild
new file mode 100644
index 000000000000..c186f88cf03c
--- /dev/null
+++ b/dev-ros/rosdiagnostic/rosdiagnostic-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command to print aggregated diagnostic contents to the command line"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"