summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:20:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:47 +0200
commitb7161826d79ca38b4a9f18e3a0c818d26e827e2c (patch)
tree5f232c9291482572a471c84dfd1f7666bb4bdbe6 /dev-ros/rosgraph/rosgraph-9999.ebuild
parentdev-ros/rosbridge_server: convert to python-single-r1 (diff)
downloadgentoo-b7161826d79ca38b4a9f18e3a0c818d26e827e2c.tar.gz
gentoo-b7161826d79ca38b4a9f18e3a0c818d26e827e2c.tar.bz2
gentoo-b7161826d79ca38b4a9f18e3a0c818d26e827e2c.zip
dev-ros/rosgraph: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-9999.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ros/rosgraph/rosgraph-9999.ebuild b/dev-ros/rosgraph/rosgraph-9999.ebuild
index 5371ed906b58..0266daff9c69 100644
--- a/dev-ros/rosgraph/rosgraph-9999.ebuild
+++ b/dev-ros/rosgraph/rosgraph-9999.ebuild
@@ -15,7 +15,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/netifaces[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep "dev-python/netifaces[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"