summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:06:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:06:31 +0200
commit384910ee7e922eab8ec6e4c374f82e632d9e99a5 (patch)
treeb0aa0b957173e03aed27220f42afd4a602db9f6e /dev-ros/roslisp
parentdev-ros/rosconsole_bridge: Initial import. Ebuild by me. (diff)
downloadgentoo-384910ee7e922eab8ec6e4c374f82e632d9e99a5.tar.gz
gentoo-384910ee7e922eab8ec6e4c374f82e632d9e99a5.tar.bz2
gentoo-384910ee7e922eab8ec6e4c374f82e632d9e99a5.zip
dev-ros/roslisp: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/roslisp')
-rw-r--r--dev-ros/roslisp/Manifest1
-rw-r--r--dev-ros/roslisp/metadata.xml5
-rw-r--r--dev-ros/roslisp/roslisp-1.9.19.ebuild24
-rw-r--r--dev-ros/roslisp/roslisp-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/roslisp/Manifest b/dev-ros/roslisp/Manifest
new file mode 100644
index 000000000000..6ad0ee559bb2
--- /dev/null
+++ b/dev-ros/roslisp/Manifest
@@ -0,0 +1 @@
+DIST roslisp-1.9.19.tar.gz 115845 SHA256 041a8f143faa6aad8d45961a113a9d258f9e2ed86f06dce045f7fd878b4f6f36 SHA512 1eb7cf6b6e6f3d82321da8caecba97ae3793213faeb0c9723ffa66448e88f819168b63246cb9362373717b65b79e26e0233440719d4805f19767d9152c664bd6 WHIRLPOOL b7b18dc537254e5112a62109bd0a2edc624446309f3221c1192ede69d50657144def74143dbc9ed17e4a0945a85f137c9688ebcc660881e8a4f2c82331bca8d5
diff --git a/dev-ros/roslisp/metadata.xml b/dev-ros/roslisp/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/roslisp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/roslisp/roslisp-1.9.19.ebuild b/dev-ros/roslisp/roslisp-1.9.19.ebuild
new file mode 100644
index 000000000000..42af580438e0
--- /dev/null
+++ b/dev-ros/roslisp/roslisp-1.9.19.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/roslisp"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="Lisp client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslang
+ dev-lisp/sbcl
+ dev-ros/rospack
+ dev-ros/rosgraph_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/roslisp/roslisp-9999.ebuild b/dev-ros/roslisp/roslisp-9999.ebuild
new file mode 100644
index 000000000000..42af580438e0
--- /dev/null
+++ b/dev-ros/roslisp/roslisp-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/roslisp"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="Lisp client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslang
+ dev-lisp/sbcl
+ dev-ros/rospack
+ dev-ros/rosgraph_msgs
+ dev-ros/std_srvs
+"
+DEPEND="${RDEPEND}"