summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:36:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:54 +0200
commit6a5e7cddeb28e7fb35cdee0a33a07c5319c1ae4e (patch)
treec11ad22d4bdf296c50a2c714631fe1136851e454 /dev-ros/rosmake/rosmake-1.14.1.ebuild
parentdev-ros/roscreate: Bump to 1.14.1. (diff)
downloadgentoo-6a5e7cddeb28e7fb35cdee0a33a07c5319c1ae4e.tar.gz
gentoo-6a5e7cddeb28e7fb35cdee0a33a07c5319c1ae4e.tar.bz2
gentoo-6a5e7cddeb28e7fb35cdee0a33a07c5319c1ae4e.zip
dev-ros/rosmake: Bump to 1.14.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.14.1.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.14.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.14.1.ebuild b/dev-ros/rosmake/rosmake-1.14.1.ebuild
new file mode 100644
index 000000000000..43392de3cae4
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.14.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"