summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-17 12:16:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-17 13:46:27 +0200
commit81af2ced0564a691c2264f2816da03d40c79a19e (patch)
treedc6b55f34c7ef124072197e01bc13c20607e851b /dev-ros/rosmaster/rosmaster-1.13.2.ebuild
parentdev-ros/roslaunch: Bump to 1.13.2. (diff)
downloadgentoo-81af2ced0564a691c2264f2816da03d40c79a19e.tar.gz
gentoo-81af2ced0564a691c2264f2816da03d40c79a19e.tar.bz2
gentoo-81af2ced0564a691c2264f2816da03d40c79a19e.zip
dev-ros/rosmaster: Bump to 1.13.2.
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.13.2.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.13.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.13.2.ebuild b/dev-ros/rosmaster/rosmaster-1.13.2.ebuild
new file mode 100644
index 000000000000..359f6a500a17
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.13.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"