summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:31:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:35 +0100
commit11b7054df18f385332ad622f1707af452d6ca064 (patch)
tree843cc0a0cac9f4e92604c0d1da3c9bec383889a4 /dev-ros/rosmaster/rosmaster-1.13.4.ebuild
parentdev-ros/roslaunch: Bump to 1.13.4. (diff)
downloadgentoo-11b7054df18f385332ad622f1707af452d6ca064.tar.gz
gentoo-11b7054df18f385332ad622f1707af452d6ca064.tar.bz2
gentoo-11b7054df18f385332ad622f1707af452d6ca064.zip
dev-ros/rosmaster: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.13.4.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.13.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.13.4.ebuild b/dev-ros/rosmaster/rosmaster-1.13.4.ebuild
new file mode 100644
index 000000000000..359f6a500a17
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.13.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"