summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:54:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:49 +0200
commit5289481e4ea62050fabb38364bb5e9856070a8ed (patch)
tree6d4179fd23be5de792cedc82ced3c3ac66d92eb1 /dev-ros/rosmsg/rosmsg-1.14.3.ebuild
parentdev-ros/rosmaster: Bump to 1.14.3. (diff)
downloadgentoo-5289481e4ea62050fabb38364bb5e9856070a8ed.tar.gz
gentoo-5289481e4ea62050fabb38364bb5e9856070a8ed.tar.bz2
gentoo-5289481e4ea62050fabb38364bb5e9856070a8ed.zip
dev-ros/rosmsg: Bump to 1.14.3.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.14.3.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.14.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.14.3.ebuild b/dev-ros/rosmsg/rosmsg-1.14.3.ebuild
new file mode 100644
index 000000000000..7189f2bbf44a
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.14.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"