summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 18:25:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:29:58 +0200
commitb0c8987ed8553bee9b62ded0521803826f92fac5 (patch)
tree71e5df5285b2687dedf86d1e15ecf2e8b5c32327 /dev-ros/rosmsg/rosmsg-1.15.7.ebuild
parentdev-ros/rosmaster: Bump to 1.15.7. (diff)
downloadgentoo-b0c8987ed8553bee9b62ded0521803826f92fac5.tar.gz
gentoo-b0c8987ed8553bee9b62ded0521803826f92fac5.tar.bz2
gentoo-b0c8987ed8553bee9b62ded0521803826f92fac5.zip
dev-ros/rosmsg: Bump to 1.15.7.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.15.7.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.15.7.ebuild b/dev-ros/rosmsg/rosmsg-1.15.7.ebuild
new file mode 100644
index 000000000000..941834eadacc
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.15.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/test_rosmaster[${PYTHON_USEDEP}] )
+"