summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:43:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:27 +0200
commitaa5eca373a439ffbd9875b5208133470fdafb91e (patch)
tree1c1c279b49b160b7f7be50c06ab77e75733a1cd2 /dev-ros/rosmsg/rosmsg-9999.ebuild
parentdev-ros/rosbag: Initial import. Ebuild by me. (diff)
downloadgentoo-aa5eca373a439ffbd9875b5208133470fdafb91e.tar.gz
gentoo-aa5eca373a439ffbd9875b5208133470fdafb91e.tar.bz2
gentoo-aa5eca373a439ffbd9875b5208133470fdafb91e.zip
dev-ros/rosmsg: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-9999.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-9999.ebuild b/dev-ros/rosmsg/rosmsg-9999.ebuild
new file mode 100644
index 000000000000..d7da61f40053
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"