summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:54:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:49 +0200
commit16ba6efd122720e4e8ebcbe75af2d7b1398d9a8d (patch)
tree4456929a3030728cc426800e7a3fe3c10a039df3 /dev-ros/rosnode/rosnode-1.14.3.ebuild
parentdev-ros/rosmsg: Bump to 1.14.3. (diff)
downloadgentoo-16ba6efd122720e4e8ebcbe75af2d7b1398d9a8d.tar.gz
gentoo-16ba6efd122720e4e8ebcbe75af2d7b1398d9a8d.tar.bz2
gentoo-16ba6efd122720e4e8ebcbe75af2d7b1398d9a8d.zip
dev-ros/rosnode: Bump to 1.14.3.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/rosnode/rosnode-1.14.3.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-1.14.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosnode/rosnode-1.14.3.ebuild b/dev-ros/rosnode/rosnode-1.14.3.ebuild
new file mode 100644
index 000000000000..e55999df9cae
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.14.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"