summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:29:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:54 +0200
commit6f08859bc671e8df2fe4171aa9ed85e447b29bfa (patch)
tree01abc98350b3298f9b983f01b3c9115821707825 /dev-ros/rosnode/rosnode-1.15.8.ebuild
parentdev-ros/rosmsg: Bump to 1.15.8. (diff)
downloadgentoo-6f08859bc671e8df2fe4171aa9ed85e447b29bfa.tar.gz
gentoo-6f08859bc671e8df2fe4171aa9ed85e447b29bfa.tar.bz2
gentoo-6f08859bc671e8df2fe4171aa9ed85e447b29bfa.zip
dev-ros/rosnode: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosnode/rosnode-1.15.8.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-1.15.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosnode/rosnode-1.15.8.ebuild b/dev-ros/rosnode/rosnode-1.15.8.ebuild
new file mode 100644
index 000000000000..c001cad5cf56
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.15.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"