summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:15:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:24 +0200
commitd5eeca3638395eb48cedc0116af3d4c5acf67833 (patch)
tree72c99eceabddc8fd03e0eaf750ea5d550d6da1ff /dev-ros/rosout/rosout-9999.ebuild
parentdev-ros/topic_tools: Initial import. Ebuild by me. (diff)
downloadgentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.tar.gz
gentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.tar.bz2
gentoo-d5eeca3638395eb48cedc0116af3d4c5acf67833.zip
dev-ros/rosout: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosout/rosout-9999.ebuild')
-rw-r--r--dev-ros/rosout/rosout-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosout/rosout-9999.ebuild b/dev-ros/rosout/rosout-9999.ebuild
new file mode 100644
index 000000000000..578c51b32a35
--- /dev/null
+++ b/dev-ros/rosout/rosout-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="System-wide logging mechanism for messages sent to the /rosout topic"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"