summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 10:31:34 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:49 +0100
commitd741f8a0385e1901a98715c4f3e087630c2c2917 (patch)
tree5fa56abb1e1765827d3fab0334f3f81f412066d3 /dev-ros/rospack/rospack-2.4.1.ebuild
parentdev-util/catkin: Install package.xml twice, once in ros_packages for fast sea... (diff)
downloadgentoo-d741f8a0385e1901a98715c4f3e087630c2c2917.tar.gz
gentoo-d741f8a0385e1901a98715c4f3e087630c2c2917.tar.bz2
gentoo-d741f8a0385e1901a98715c4f3e087630c2c2917.zip
dev-ros/rospack: Bump to 2.4.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rospack/rospack-2.4.1.ebuild')
-rw-r--r--dev-ros/rospack/rospack-2.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rospack/rospack-2.4.1.ebuild b/dev-ros/rospack/rospack-2.4.1.ebuild
new file mode 100644
index 000000000000..fadaa0c3cfcd
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ "
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"