summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 09:59:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:51 +0100
commit6d9744df47f8cd1db2eea68d4aade21282bce202 (patch)
tree53c20f85adb42d70a69f85481dc197882def59fb /dev-ros/rosparam/rosparam-1.13.0.ebuild
parentdev-ros/rosout: Bump to 1.13.0. (diff)
downloadgentoo-6d9744df47f8cd1db2eea68d4aade21282bce202.tar.gz
gentoo-6d9744df47f8cd1db2eea68d4aade21282bce202.tar.bz2
gentoo-6d9744df47f8cd1db2eea68d4aade21282bce202.zip
dev-ros/rosparam: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosparam/rosparam-1.13.0.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-1.13.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-1.13.0.ebuild b/dev-ros/rosparam/rosparam-1.13.0.ebuild
new file mode 100644
index 000000000000..df24a93de785
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-1.13.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"