summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-14 16:40:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-15 07:57:45 +0100
commit920a9bd696acbc0888ad5b47a9dd67cbd61f2c04 (patch)
tree37e8c281e8013b628134c7d2b0b5c1707c47ade8 /dev-ros/rospy/rospy-1.13.5.ebuild
parentdev-ros/roscpp: Bump to 1.13.5. (diff)
downloadgentoo-920a9bd696acbc0888ad5b47a9dd67cbd61f2c04.tar.gz
gentoo-920a9bd696acbc0888ad5b47a9dd67cbd61f2c04.tar.bz2
gentoo-920a9bd696acbc0888ad5b47a9dd67cbd61f2c04.zip
dev-ros/rospy: Bump to 1.13.5.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/rospy/rospy-1.13.5.ebuild')
-rw-r--r--dev-ros/rospy/rospy-1.13.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rospy/rospy-1.13.5.ebuild b/dev-ros/rospy/rospy-1.13.5.ebuild
new file mode 100644
index 000000000000..343c2a3a7d1f
--- /dev/null
+++ b/dev-ros/rospy/rospy-1.13.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roscpp[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ # Other tests need these nodes
+ exeinto /usr/share/${PN}
+ doexe test_nodes/*
+}