summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:23 +0100
commit9168fb1dc17bdca46246d51aa18a188c29d85f3d (patch)
treec385839e3e4bcddbe062a65a40fb8fc12625dd51 /dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild
parentdev-ros/rosserial_msgs: Bump to 0.8.0. (diff)
downloadgentoo-9168fb1dc17bdca46246d51aa18a188c29d85f3d.tar.gz
gentoo-9168fb1dc17bdca46246d51aa18a188c29d85f3d.tar.bz2
gentoo-9168fb1dc17bdca46246d51aa18a188c29d85f3d.zip
dev-ros/rosserial_python: Bump to 0.8.0.
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild')
-rw-r--r--dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild b/dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild
new file mode 100644
index 000000000000..62cd44b9a578
--- /dev/null
+++ b/dev-ros/rosserial_python/rosserial_python-0.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A Python-based implementation of the ROS serial protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"