summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-14 12:42:24 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-14 13:05:02 +0200
commit812853001b2cc112c20862f9c8b3180131a5528b (patch)
tree8825f30e3f6cd4b9bf27da127ecadc6aada410ff /dev-ros/rosserial_server
parentdev-ros/rosserial_server: remove merged patch (diff)
downloadgentoo-812853001b2cc112c20862f9c8b3180131a5528b.tar.gz
gentoo-812853001b2cc112c20862f9c8b3180131a5528b.tar.bz2
gentoo-812853001b2cc112c20862f9c8b3180131a5528b.zip
dev-ros/rosserial_server: Remove old
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_server')
-rw-r--r--dev-ros/rosserial_server/Manifest1
-rw-r--r--dev-ros/rosserial_server/files/boost170.patch71
-rw-r--r--dev-ros/rosserial_server/rosserial_server-0.8.0.ebuild24
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-ros/rosserial_server/Manifest b/dev-ros/rosserial_server/Manifest
index b7fd4069d988..cb185c6583e7 100644
--- a/dev-ros/rosserial_server/Manifest
+++ b/dev-ros/rosserial_server/Manifest
@@ -1,2 +1 @@
-DIST rosserial-0.8.0.tar.gz 312494 BLAKE2B f65d42ebdc47125a7dfb9b3a999f53640812bc9741f43a5b451fbe449d6d23537face7ca148b2b952c401bb439cee05693f5663e423e70d9df3bbde0d07fbb0a SHA512 ee2f4b3b39fd3be47cbaaed7bfbe08057b1525a12f31dd685d80683ec1ddc89ff43157cc0f09583e68ccc6e35009fda73efa8a74dad6c5bba4b46f4ad6a155d0
DIST rosserial-0.9.1.tar.gz 318452 BLAKE2B 3901c9fb8813cc93b31a4286272508fb2e8026a540becc1f58d674195cc90354ba43aa7307891d8d2fc9b7ef594fa5597d49f2209f4862dc5467f57e49e0c5b4 SHA512 a484983e1e4c3f86b311b07bc402d5984f9161dc025bb7017fd936e3551368b6af00484724ebaed16777a45b40ab2323ea25309fe7f313ee52a7245b035ccf17
diff --git a/dev-ros/rosserial_server/files/boost170.patch b/dev-ros/rosserial_server/files/boost170.patch
deleted file mode 100644
index cbf106fc9acd..000000000000
--- a/dev-ros/rosserial_server/files/boost170.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Index: rosserial_server/include/rosserial_server/async_read_buffer.h
-===================================================================
---- rosserial_server.orig/include/rosserial_server/async_read_buffer.h
-+++ rosserial_server/include/rosserial_server/async_read_buffer.h
-@@ -166,7 +166,7 @@ private:
-
- // Post the callback rather than executing it here so, so that we have a chance to do the cleanup
- // below prior to it actually getting run, in the event that the callback queues up another read.
-- stream_.get_io_service().post(boost::bind(read_success_callback_, stream));
-+ static_cast<boost::asio::io_service&>(stream_.get_executor().context()).post(boost::bind(read_success_callback_, stream));
-
- // Resetting these values clears our state so that we know there isn't a callback pending.
- read_requested_bytes_ = 0;
-Index: rosserial_server/include/rosserial_server/udp_stream.h
-===================================================================
---- rosserial_server.orig/include/rosserial_server/udp_stream.h
-+++ rosserial_server/include/rosserial_server/udp_stream.h
-@@ -48,7 +48,6 @@ namespace rosserial_server
- {
-
- using boost::asio::ip::udp;
--using boost::asio::handler_type;
-
-
- class UdpStream : public udp::socket
-@@ -62,9 +61,9 @@ public:
- {
- boost::system::error_code ec;
- const protocol_type protocol = server_endpoint.protocol();
-- this->get_service().open(this->get_implementation(), protocol, ec);
-+ udp::socket::open(protocol, ec);
- boost::asio::detail::throw_error(ec, "open");
-- this->get_service().bind(this->get_implementation(), server_endpoint, ec);
-+ bind(server_endpoint, ec);
- boost::asio::detail::throw_error(ec, "bind");
-
- client_endpoint_ = client_endpoint;
-@@ -76,6 +75,8 @@ public:
- async_write_some(const ConstBufferSequence& buffers,
- BOOST_ASIO_MOVE_ARG(WriteHandler) handler)
- {
-+ return async_send(buffers, handler);
-+#if 0
- // If you get an error on the following line it means that your handler does
- // not meet the documented type requirements for a WriteHandler.
- BOOST_ASIO_WRITE_HANDLER_CHECK(WriteHandler, handler) type_check;
-@@ -94,6 +95,7 @@ public:
- this->get_implementation(), buffers, client_endpoint_, 0,
- BOOST_ASIO_MOVE_CAST(WriteHandler)(handler));
- #endif
-+#endif
- }
-
- template <typename MutableBufferSequence, typename ReadHandler>
-@@ -102,6 +104,8 @@ public:
- async_read_some(const MutableBufferSequence& buffers,
- BOOST_ASIO_MOVE_ARG(ReadHandler) handler)
- {
-+ return async_receive(buffers, handler);
-+#if 0
- // If you get an error on the following line it means that your handler does
- // not meet the documented type requirements for a ReadHandler.
- BOOST_ASIO_READ_HANDLER_CHECK(ReadHandler, handler) type_check;
-@@ -119,6 +123,7 @@ public:
- this->get_implementation(), buffers, client_endpoint_, 0,
- BOOST_ASIO_MOVE_CAST(ReadHandler)(handler));
- #endif
-+#endif
- }
-
- private:
diff --git a/dev-ros/rosserial_server/rosserial_server-0.8.0.ebuild b/dev-ros/rosserial_server/rosserial_server-0.8.0.ebuild
deleted file mode 100644
index c3d3ee32e16b..000000000000
--- a/dev-ros/rosserial_server/rosserial_server-0.8.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="C++ implementation of the rosserial server side"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- dev-ros/topic_tools
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}
- dev-ros/rosserial_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
-PATCHES=( "${FILESDIR}/boost170.patch" )