summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:32 +0100
commitf59452a678c41dfb7a712bae1067895a0425a271 (patch)
tree5df8fe5fd7abf820d511219ba1195bafaaf93f39 /dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild
parentdev-ros/rosserial_server: Bump to 0.8.0. (diff)
downloadgentoo-f59452a678c41dfb7a712bae1067895a0425a271.tar.gz
gentoo-f59452a678c41dfb7a712bae1067895a0425a271.tar.bz2
gentoo-f59452a678c41dfb7a712bae1067895a0425a271.zip
dev-ros/rosserial_tivac: Bump to 0.8.0.
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild')
-rw-r--r--dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild b/dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild
new file mode 100644
index 000000000000..633a059710c1
--- /dev/null
+++ b/dev-ros/rosserial_tivac/rosserial_tivac-0.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Definitions for rosserial_client targets for TivaC Launchpad evaluation boards."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosserial_client[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"