summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-04 22:18:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-04 22:18:41 +0100
commitfdebad17e9794198c8072354d8db14bb226d4803 (patch)
tree6e22674874433284589fb897740881164284473e /dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
parentdev-ros/rosserial_windows: Bump to 0.7.7. (diff)
downloadgentoo-fdebad17e9794198c8072354d8db14bb226d4803.tar.gz
gentoo-fdebad17e9794198c8072354d8db14bb226d4803.tar.bz2
gentoo-fdebad17e9794198c8072354d8db14bb226d4803.zip
dev-ros/rosserial_xbee: Bump to 0.7.7.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
new file mode 100644
index 000000000000..4e936b3e9784
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"