summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:43 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-11-02 14:47:43 +0100
commit985c7113f80de9bd2f45b975e6c70ad063458ec5 (patch)
tree85927a79b299fb384ccadf5341a3abe60153717b /dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild
parentdev-ros/rosserial_windows: Bump to 0.8.0. (diff)
downloadgentoo-985c7113f80de9bd2f45b975e6c70ad063458ec5.tar.gz
gentoo-985c7113f80de9bd2f45b975e6c70ad063458ec5.tar.bz2
gentoo-985c7113f80de9bd2f45b975e6c70ad063458ec5.zip
dev-ros/rosserial_xbee: Bump to 0.8.0.
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild
new file mode 100644
index 000000000000..74085bbf45a4
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-0.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"