summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 14:50:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 14:50:04 +0200
commite1d5127ecbe4283d9cbfe5efd5d2b10967e0a4d5 (patch)
treea3c0e00ad5ac045b89bf5d77c31f7b1f18ec65ea /dev-ros/rosservice/rosservice-1.12.4.ebuild
parentdev-ros/rosparam: Bump to 1.12.4. (diff)
downloadgentoo-e1d5127ecbe4283d9cbfe5efd5d2b10967e0a4d5.tar.gz
gentoo-e1d5127ecbe4283d9cbfe5efd5d2b10967e0a4d5.tar.bz2
gentoo-e1d5127ecbe4283d9cbfe5efd5d2b10967e0a4d5.zip
dev-ros/rosservice: Bump to 1.12.4.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.12.4.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.12.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.12.4.ebuild b/dev-ros/rosservice/rosservice-1.12.4.ebuild
new file mode 100644
index 000000000000..891fbc7248a1
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.12.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"