summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:29:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:55 +0200
commitb1b38d2ddfb9144b43e7210dc38aab41c15be5a2 (patch)
tree5a0ba87b069bac1254947aad38cf9a25291497d1 /dev-ros/rosservice/rosservice-1.15.8.ebuild
parentdev-ros/rosparam: Bump to 1.15.8. (diff)
downloadgentoo-b1b38d2ddfb9144b43e7210dc38aab41c15be5a2.tar.gz
gentoo-b1b38d2ddfb9144b43e7210dc38aab41c15be5a2.tar.bz2
gentoo-b1b38d2ddfb9144b43e7210dc38aab41c15be5a2.zip
dev-ros/rosservice: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.15.8.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.15.8.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.15.8.ebuild b/dev-ros/rosservice/rosservice-1.15.8.ebuild
new file mode 100644
index 000000000000..f997c822e5bf
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.15.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"