summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:50:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commit4c550284cb44ab44fa66a88ece71280a243449bf (patch)
tree82292f913f6377bd2f4fd360718d076210240621 /dev-ros/rostest/rostest-1.12.1.ebuild
parentdev-ros/rosservice: Bump to 1.12.1. (diff)
downloadgentoo-4c550284cb44ab44fa66a88ece71280a243449bf.tar.gz
gentoo-4c550284cb44ab44fa66a88ece71280a243449bf.tar.bz2
gentoo-4c550284cb44ab44fa66a88ece71280a243449bf.zip
dev-ros/rostest: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rostest/rostest-1.12.1.ebuild')
-rw-r--r--dev-ros/rostest/rostest-1.12.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rostest/rostest-1.12.1.ebuild b/dev-ros/rostest/rostest-1.12.1.ebuild
new file mode 100644
index 000000000000..60104a36d6d0
--- /dev/null
+++ b/dev-ros/rostest/rostest-1.12.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Integration test suite based on roslaunch that is compatible with xUnit frameworks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ ${RDEPEND}
+ dev-cpp/gtest
+ )"