summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-18 21:15:43 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 21:15:43 +0200
commit66136c17d2c4c57b699f4846795c94f0b518bb60 (patch)
tree34479063f824fdd76ab2c5d8a0520727ed6079f8 /dev-ros/rostest/rostest-1.15.10-r1.ebuild
parentdev-ros/rosserial_server: Depend on dev-libs/boost:=[threads(+)] (diff)
downloadgentoo-66136c17d2c4c57b699f4846795c94f0b518bb60.tar.gz
gentoo-66136c17d2c4c57b699f4846795c94f0b518bb60.tar.bz2
gentoo-66136c17d2c4c57b699f4846795c94f0b518bb60.zip
dev-ros/rostest: Depend on dev-libs/boost:=[threads(+)]
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ros/rostest/rostest-1.15.10-r1.ebuild')
-rw-r--r--dev-ros/rostest/rostest-1.15.10-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rostest/rostest-1.15.10-r1.ebuild b/dev-ros/rostest/rostest-1.15.10-r1.ebuild
new file mode 100644
index 000000000000..1f8991fc0261
--- /dev/null
+++ b/dev-ros/rostest/rostest-1.15.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Integration test suite based on roslaunch compatible with xUnit frameworks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ ${RDEPEND}
+ dev-ros/rosservice
+ dev-cpp/gtest
+ dev-ros/rostopic
+ )"