summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-09 10:59:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-09 12:39:03 +0100
commit2d476af19c4484287a286697aab66a9c91858a2f (patch)
treebcf1175ba79109402fd0349ed4fd931cea7a4574 /dev-ros/roswtf/roswtf-1.13.6.ebuild
parentdev-ros/xmlrpcpp: Bump to 1.13.6. (diff)
downloadgentoo-2d476af19c4484287a286697aab66a9c91858a2f.tar.gz
gentoo-2d476af19c4484287a286697aab66a9c91858a2f.tar.bz2
gentoo-2d476af19c4484287a286697aab66a9c91858a2f.zip
dev-ros/roswtf: Bump to 1.13.6.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.13.6.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.13.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.13.6.ebuild b/dev-ros/roswtf/roswtf-1.13.6.ebuild
new file mode 100644
index 000000000000..396feee7b7a8
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.13.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-util/rosdep[${PYTHON_USEDEP}]
+ dev-util/rosinstall[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"