summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:14:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:14:50 +0200
commit6e45cd7754d48422d004bef8aad46c3c7f9734b0 (patch)
treee6f306afd5726111eb60e8282599e4e4086f9ed0 /dev-ros/rqt_action/rqt_action-9999.ebuild
parentdev-ros/rqt_msg: Initial import. Ebuild by me. (diff)
downloadgentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.tar.gz
gentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.tar.bz2
gentoo-6e45cd7754d48422d004bef8aad46c3c7f9734b0.zip
dev-ros/rqt_action: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_action/rqt_action-9999.ebuild')
-rw-r--r--dev-ros/rqt_action/rqt_action-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_action/rqt_action-9999.ebuild b/dev-ros/rqt_action/rqt_action-9999.ebuild
new file mode 100644
index 000000000000..f1b6cef67d46
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"