summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-06 14:18:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-06 14:32:52 +0200
commitcdd108142bb018b5386dc3f74d489fd86d4476d1 (patch)
tree4e22f9daf8ca76d0d958a0208938a13cdc342682 /dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
parentdev-ros/rqt_dep: bump to 0.4.12 (diff)
downloadgentoo-cdd108142bb018b5386dc3f74d489fd86d4476d1.tar.gz
gentoo-cdd108142bb018b5386dc3f74d489fd86d4476d1.tar.bz2
gentoo-cdd108142bb018b5386dc3f74d489fd86d4476d1.zip
dev-ros/rqt_bag: bump to 0.5.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild')
-rw-r--r--dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild b/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
new file mode 100644
index 000000000000..9e3b5a9ca419
--- /dev/null
+++ b/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_bag"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+"