summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:17:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:17:11 +0200
commitea12b4065579bf11ad117f51c718ca25cfe7787e (patch)
treefbd5bbd4c1e2a46c7ad870bcea024c8061ff0fce /dev-ros/rqt_console/rqt_console-9999.ebuild
parentdev-ros/rqt_bag_plugins: Initial import. Ebuild by me. (diff)
downloadgentoo-ea12b4065579bf11ad117f51c718ca25cfe7787e.tar.gz
gentoo-ea12b4065579bf11ad117f51c718ca25cfe7787e.tar.bz2
gentoo-ea12b4065579bf11ad117f51c718ca25cfe7787e.zip
dev-ros/rqt_console: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_console/rqt_console-9999.ebuild')
-rw-r--r--dev-ros/rqt_console/rqt_console-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_console/rqt_console-9999.ebuild b/dev-ros/rqt_console/rqt_console-9999.ebuild
new file mode 100644
index 000000000000..d8096e36c72a
--- /dev/null
+++ b/dev-ros/rqt_console/rqt_console-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and filtering ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_logger_level[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"