summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-14 09:58:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-14 10:33:03 +0100
commita589d194b60b23c9c9c075f12c4bf3028a8e6295 (patch)
tree0b9c98bee6a40cc732c38d816ca03750f3690133 /dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild
parentdev-ros/rqt_console: Bump to 0.4.3. (diff)
downloadgentoo-a589d194b60b23c9c9c075f12c4bf3028a8e6295.tar.gz
gentoo-a589d194b60b23c9c9c075f12c4bf3028a8e6295.tar.bz2
gentoo-a589d194b60b23c9c9c075f12c4bf3028a8e6295.zip
dev-ros/rqt_dep: Bump to 0.4.3.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild')
-rw-r--r--dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild b/dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild
new file mode 100644
index 000000000000..5a5962846d7e
--- /dev/null
+++ b/dev-ros/rqt_dep/rqt_dep-0.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"