summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:20:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:20:18 +0200
commite4ae2ae93909deaa3cb2d71faa0eb07aa70aef06 (patch)
tree79877bdfe4cd1a54046d9f1422317cd88e1b5c47 /dev-ros/rqt_graph/rqt_graph-9999.ebuild
parentdev-ros/rqt_dep: Initial import. Ebuild by me. (diff)
downloadgentoo-e4ae2ae93909deaa3cb2d71faa0eb07aa70aef06.tar.gz
gentoo-e4ae2ae93909deaa3cb2d71faa0eb07aa70aef06.tar.bz2
gentoo-e4ae2ae93909deaa3cb2d71faa0eb07aa70aef06.zip
dev-ros/rqt_graph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_graph/rqt_graph-9999.ebuild')
-rw-r--r--dev-ros/rqt_graph/rqt_graph-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/rqt_graph-9999.ebuild b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
new file mode 100644
index 000000000000..9cbcb40f8b5b
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"