summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-05 12:39:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-05 12:53:56 +0200
commit34b1ad80dbd1c796db71b055a390e3e82071a968 (patch)
treefc1a247f59950866597fa8ea30f4b6631c9ba7ab /dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild
parentdev-ros/rqt_gui: Bump to 0.3.1. (diff)
downloadgentoo-34b1ad80dbd1c796db71b055a390e3e82071a968.tar.gz
gentoo-34b1ad80dbd1c796db71b055a390e3e82071a968.tar.bz2
gentoo-34b1ad80dbd1c796db71b055a390e3e82071a968.zip
dev-ros/rqt_gui_cpp: Bump to 0.3.1.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild')
-rw-r--r--dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild
new file mode 100644
index 000000000000..2aa04732fa45
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ >=dev-ros/qt_gui_cpp-0.3.0
+ >=dev-ros/qt_gui-0.3.0
+ dev-ros/roscpp
+ dev-ros/nodelet
+"
+DEPEND="${RDEPEND}"