summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:42:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:05 +0200
commit83ca6fcd30deef8ad9c13d1d02ab931903519190 (patch)
treef10c9911a06409cea29c77f4860d02d55e62dc8c /dev-ros/rqt_launch
parentdev-ros/rqt_launch: remove old (diff)
downloadgentoo-83ca6fcd30deef8ad9c13d1d02ab931903519190.tar.gz
gentoo-83ca6fcd30deef8ad9c13d1d02ab931903519190.tar.bz2
gentoo-83ca6fcd30deef8ad9c13d1d02ab931903519190.zip
dev-ros/rqt_launch: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_launch')
-rw-r--r--dev-ros/rqt_launch/Manifest1
-rw-r--r--dev-ros/rqt_launch/metadata.xml2
-rw-r--r--dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild26
-rw-r--r--dev-ros/rqt_launch/rqt_launch-9999.ebuild5
4 files changed, 30 insertions, 4 deletions
diff --git a/dev-ros/rqt_launch/Manifest b/dev-ros/rqt_launch/Manifest
index 7bb8c4d74093..ae8fbb053628 100644
--- a/dev-ros/rqt_launch/Manifest
+++ b/dev-ros/rqt_launch/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_launch-0.4.8.tar.gz 11471 SHA256 6c3fcde64a2a4458a010ec5dbd7217cf61170ff3a90529ba0d000f43437c2c54 SHA512 83a40eca2c2282f2e5e397332b5b61b60ac27312b31ad21c21f03243e1b28961d96ba93f4e8c5043e05791c85d1fa88fee461f4b457934fcb68e47a60239cc89 WHIRLPOOL c7bfdec8d9d08ccab16f026a15a33393bf37acef158df3b90bc746df2bb9af8d2e94d80dd33cfd97ee15b6d020b3c26b374351087218c0374b3b6fab4e1d807a
diff --git a/dev-ros/rqt_launch/metadata.xml b/dev-ros/rqt_launch/metadata.xml
index cb473d142b8e..ca85215d435c 100644
--- a/dev-ros/rqt_launch/metadata.xml
+++ b/dev-ros/rqt_launch/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_launch</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild b/dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild
new file mode 100644
index 000000000000..17b433a783ae
--- /dev/null
+++ b/dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_launch"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Easy view of .launch files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_console[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_launch/rqt_launch-9999.ebuild b/dev-ros/rqt_launch/rqt_launch-9999.ebuild
index 3af3fdee2d47..17b433a783ae 100644
--- a/dev-ros/rqt_launch/rqt_launch-9999.ebuild
+++ b/dev-ros/rqt_launch/rqt_launch-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_launch"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin