summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-06 14:16:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-06 14:32:52 +0200
commita21569d3b6ea289e5b86beae269c3bea88b2d1c0 (patch)
tree0d7bdc29ce7c946f4393f7307398af95f990f067 /dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
parentdev-ros/rqt_publisher: bump to 0.4.10 (diff)
downloadgentoo-a21569d3b6ea289e5b86beae269c3bea88b2d1c0.tar.gz
gentoo-a21569d3b6ea289e5b86beae269c3bea88b2d1c0.tar.bz2
gentoo-a21569d3b6ea289e5b86beae269c3bea88b2d1c0.zip
dev-ros/rqt_pose_view: bump to 0.5.11
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
new file mode 100644
index 000000000000..cd3b6a564f73
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_pose_view"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyopengl[\${PYTHON_USEDEP}]")
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"