summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:41:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:59 +0200
commit3acdd8931382a385349f37e8bf78539f96848450 (patch)
tree6c5d62d10ba189f9fb96874090704f9734dd2847 /dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
parentdev-ros/rqt_plot: convert to python-single-r1 (diff)
downloadgentoo-3acdd8931382a385349f37e8bf78539f96848450.tar.gz
gentoo-3acdd8931382a385349f37e8bf78539f96848450.tar.bz2
gentoo-3acdd8931382a385349f37e8bf78539f96848450.zip
dev-ros/rqt_pose_view: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
index dbddd92715ea..903a748d5bfa 100644
--- a/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-9999.ebuild
@@ -15,14 +15,14 @@ IUSE=""
RDEPEND="
dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pyopengl[${PYTHON_USEDEP}]
- dev-ros/python_qt_binding[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostopic[${PYTHON_USEDEP}]
- dev-ros/rqt_gui[${PYTHON_USEDEP}]
- dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
- dev-ros/tf[${PYTHON_USEDEP}]
- dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyopengl[\${PYTHON_USEDEP}]")
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}"