summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:03:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:42 +0200
commitae5f6c4147f577e1d4e5af1fcac1667ce190ceb2 (patch)
tree5095c1c1cc4c3a2be5a301bd875d9a173e490937 /dev-ros/rqt_publisher
parentdev-ros/rqt_gui: Remove old (diff)
downloadgentoo-ae5f6c4147f577e1d4e5af1fcac1667ce190ceb2.tar.gz
gentoo-ae5f6c4147f577e1d4e5af1fcac1667ce190ceb2.tar.bz2
gentoo-ae5f6c4147f577e1d4e5af1fcac1667ce190ceb2.zip
dev-ros/rqt_publisher: bump to 0.4.9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_publisher')
-rw-r--r--dev-ros/rqt_publisher/Manifest1
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.4.9.ebuild26
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-9999.ebuild5
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-ros/rqt_publisher/Manifest b/dev-ros/rqt_publisher/Manifest
index 8b984d2d4a7a..0d0ba9cb0113 100644
--- a/dev-ros/rqt_publisher/Manifest
+++ b/dev-ros/rqt_publisher/Manifest
@@ -1,2 +1,3 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 BLAKE2B 5efebfa64dcc587822e558b5527a2ef2e33adc8adcb45800876e278be5ccdacbaef93b0f9dfbb7b98972fd5cffb4fcddee80e9522a4135a736d744765c2490ed SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7
DIST rqt_publisher-0.4.8.tar.gz 10391 BLAKE2B 558aef7e411dcf500fe3bf1a76985dd63c9f4b1936dd878fad22a61aab03206a10325f81329cfba24105cd041e28b389da009ceabd559c55b68e6b4411c8aae1 SHA512 87a325c9599b68171f5e014524946ab0a311872035c8b23a7234f17854d7e7f91916a6db856331b5e9958d098197b55a2e799a5b0d232bb32dd420acd070421e
+DIST rqt_publisher-0.4.9.tar.gz 10662 BLAKE2B aa5911433152237e1a0c11b382ca825bee1f4309fccd9b674f0ca7a24215fa94515bbae3c29afad5ce9f8b0f0afc254e92b36cfccd0687980562771e73a3a4d2 SHA512 5828edebe19bbb0e771628ba53e73d5c6a2c58d7b54cd278c956bb926f51e17662d2bbb4d4000aa85140ee33612917a8e3f95a203dd97c1abba6d0f495000adb
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.4.9.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.4.9.ebuild
new file mode 100644
index 000000000000..1f99335e6af2
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.4.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
index b4dc8d08ed02..1f99335e6af2 100644
--- a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
+++ b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin