summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:23:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:23:54 +0200
commit2917f8a8cc35f58527a0b9134d595584a0236b45 (patch)
tree0e6d1c2cd31a58fb158f5d8e5223b9ebac45b0d1 /dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
parentdev-ros/rqt_publisher: Initial import. Ebuild by me. (diff)
downloadgentoo-2917f8a8cc35f58527a0b9134d595584a0236b45.tar.gz
gentoo-2917f8a8cc35f58527a0b9134d595584a0236b45.tar.bz2
gentoo-2917f8a8cc35f58527a0b9134d595584a0236b45.zip
dev-ros/rqt_py_common: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_py_common/rqt_py_common-9999.ebuild')
-rw-r--r--dev-ros/rqt_py_common/rqt_py_common-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild b/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
new file mode 100644
index 000000000000..cff8866ba475
--- /dev/null
+++ b/dev-ros/rqt_py_common/rqt_py_common-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for rqt plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"