summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:24:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:24:27 +0200
commit32f7d5c3d9827e0e9cf10d285fd94636622d03ca (patch)
tree2c56dc91309532c1844ca00bea64bcfaf5c1a86f /dev-ros/rqt_py_console
parentdev-ros/rqt_py_common: Initial import. Ebuild by me. (diff)
downloadgentoo-32f7d5c3d9827e0e9cf10d285fd94636622d03ca.tar.gz
gentoo-32f7d5c3d9827e0e9cf10d285fd94636622d03ca.tar.bz2
gentoo-32f7d5c3d9827e0e9cf10d285fd94636622d03ca.zip
dev-ros/rqt_py_console: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_py_console')
-rw-r--r--dev-ros/rqt_py_console/Manifest1
-rw-r--r--dev-ros/rqt_py_console/metadata.xml5
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.3.12.ebuild27
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-9999.ebuild27
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_console/Manifest b/dev-ros/rqt_py_console/Manifest
new file mode 100644
index 000000000000..a503bd56f8f3
--- /dev/null
+++ b/dev-ros/rqt_py_console/Manifest
@@ -0,0 +1 @@
+DIST rqt_common_plugins-0.3.12.tar.gz 231733 SHA256 602ceea814b152865cd55c140565ec82d72277d9de75b869ce9fd3ac5a17b749 SHA512 567fb85324a85ef935379762026f7f3b5fbe491f61d947c273c1d138286acb919a2f458151b7137587bddbe028617934a75695a165fc7e7e6fd4b4cd87247b7d WHIRLPOOL d49809544f3de32129233c562f643afeed599b4f42688050aa433023188467243409ac048464eac05fc06f9a20c9d8992946dc68db0b01d7bcfde585a65fc42b
diff --git a/dev-ros/rqt_py_console/metadata.xml b/dev-ros/rqt_py_console/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rqt_py_console/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.3.12.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.3.12.ebuild
new file mode 100644
index 000000000000..6498ac8b31e5
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.3.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild b/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild
new file mode 100644
index 000000000000..6498ac8b31e5
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"