summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 11:26:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:28 +0200
commitb89721d04eca70a0d8cb6b3883b39fc042a8919d (patch)
tree057c1944a285d2547186da5934799147779bfd26 /dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild
parentdev-ros/rqt_robot_monitor: remove old (diff)
downloadgentoo-b89721d04eca70a0d8cb6b3883b39fc042a8919d.tar.gz
gentoo-b89721d04eca70a0d8cb6b3883b39fc042a8919d.tar.bz2
gentoo-b89721d04eca70a0d8cb6b3883b39fc042a8919d.zip
dev-ros/rqt_robot_monitor: bump to 0.5.7 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild')
-rw-r--r--dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild b/dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild
new file mode 100644
index 000000000000..c510a0e991c0
--- /dev/null
+++ b/dev-ros/rqt_robot_monitor/rqt_robot_monitor-0.5.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_monitor"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Displays diagnostics_agg topics messages that are published by diagnostic_aggregator"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_bag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"