summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-11 10:04:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-11 10:04:02 +0200
commit36594c85197c406f492eed5c0e7213efb1664e52 (patch)
tree1472150ba96a78f9c231a4fe9779c06225bbc038 /dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild
parentdev-ros/rqt_robot_monitor: Bump to 0.5.2. (diff)
downloadgentoo-36594c85197c406f492eed5c0e7213efb1664e52.tar.gz
gentoo-36594c85197c406f492eed5c0e7213efb1664e52.tar.bz2
gentoo-36594c85197c406f492eed5c0e7213efb1664e52.zip
dev-ros/rqt_robot_steering: Bump to 0.5.2.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild')
-rw-r--r--dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild b/dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild
new file mode 100644
index 000000000000..9e34fafd50af
--- /dev/null
+++ b/dev-ros/rqt_robot_steering/rqt_robot_steering-0.5.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for steering a robot using Twist messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"