summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:20:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:15 +0100
commit853e9a39db546261bace06d2d0775e16d8df9727 (patch)
tree679dfc3f41a45e52827c26862c03e23f2ee5002d /dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild
parentdev-ros/rqt_rviz: Bump to 0.5.6. (diff)
downloadgentoo-853e9a39db546261bace06d2d0775e16d8df9727.tar.gz
gentoo-853e9a39db546261bace06d2d0775e16d8df9727.tar.bz2
gentoo-853e9a39db546261bace06d2d0775e16d8df9727.zip
dev-ros/rqt_tf_tree: Bump to 0.5.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild')
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild
new file mode 100644
index 000000000000..c678b3ae7ab9
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.5.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"