summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:26:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:26:53 +0200
commitecba7dd6cd2f3a7f21461a9f99173d4b73d38b2e (patch)
treeb92ab84a0834eb96f14517bb15eef734a5250125 /dev-ros/rqt_top/rqt_top-9999.ebuild
parentdev-ros/rqt_srv: Initial import. Ebuild by me. (diff)
downloadgentoo-ecba7dd6cd2f3a7f21461a9f99173d4b73d38b2e.tar.gz
gentoo-ecba7dd6cd2f3a7f21461a9f99173d4b73d38b2e.tar.bz2
gentoo-ecba7dd6cd2f3a7f21461a9f99173d4b73d38b2e.zip
dev-ros/rqt_top: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_top/rqt_top-9999.ebuild')
-rw-r--r--dev-ros/rqt_top/rqt_top-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_top/rqt_top-9999.ebuild b/dev-ros/rqt_top/rqt_top-9999.ebuild
new file mode 100644
index 000000000000..84e9f0b8486b
--- /dev/null
+++ b/dev-ros/rqt_top/rqt_top-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="RQT plugin for monitoring ROS processes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"