summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-10 10:54:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-10 11:34:51 +0100
commit2fa2470578db4429bc3f42e0704e5b73f3b5ae68 (patch)
treea630171f8db39999ca5a6fa7dc421a113db91a61 /dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild
parentdev-ros/rqt_top: Bump to 0.3.13. (diff)
downloadgentoo-2fa2470578db4429bc3f42e0704e5b73f3b5ae68.tar.gz
gentoo-2fa2470578db4429bc3f42e0704e5b73f3b5ae68.tar.bz2
gentoo-2fa2470578db4429bc3f42e0704e5b73f3b5ae68.zip
dev-ros/rqt_topic: Bump to 0.3.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild')
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild b/dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild
new file mode 100644
index 000000000000..8c028b2f69b4
--- /dev/null
+++ b/dev-ros/rqt_topic/rqt_topic-0.3.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"