summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-04 22:41:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-04 22:41:13 +0100
commit927d987feae28e4d4baefd90a7265afb185be9de (patch)
tree89fd7efc5086d7a3bb7e9c105a41d9608b2b5f5e /dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild
parentdev-ros/rqt_topic: Remove old (diff)
downloadgentoo-927d987feae28e4d4baefd90a7265afb185be9de.tar.gz
gentoo-927d987feae28e4d4baefd90a7265afb185be9de.tar.bz2
gentoo-927d987feae28e4d4baefd90a7265afb185be9de.zip
dev-ros/rqt_topic: bump to 0.4.10
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild b/dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild
new file mode 100644
index 000000000000..bf621ebec809
--- /dev/null
+++ b/dev-ros/rqt_topic/rqt_topic-0.4.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_topic"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"