summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:16:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:11 +0100
commit0942e6b0f725cded006acbe72cf0745a3658436c (patch)
tree4da18e13ab041a0d0eda4d136f8b2bf4d5a00f3c /dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild
parentdev-ros/rqt_top: Bump to 0.4.4. (diff)
downloadgentoo-0942e6b0f725cded006acbe72cf0745a3658436c.tar.gz
gentoo-0942e6b0f725cded006acbe72cf0745a3658436c.tar.bz2
gentoo-0942e6b0f725cded006acbe72cf0745a3658436c.zip
dev-ros/rqt_topic: Bump to 0.4.4.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild')
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild b/dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild
new file mode 100644
index 000000000000..c7867039678a
--- /dev/null
+++ b/dev-ros/rqt_topic/rqt_topic-0.4.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"