summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:09:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:12 +0200
commit172dcc19bc194e9c5f60ac7789428d5056b41ca9 (patch)
treecc3888246eb8f5c425cdadfcead273d5540dcc9e /dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild
parentdev-ros/rqt_topic: remove old (diff)
downloadgentoo-172dcc19bc194e9c5f60ac7789428d5056b41ca9.tar.gz
gentoo-172dcc19bc194e9c5f60ac7789428d5056b41ca9.tar.bz2
gentoo-172dcc19bc194e9c5f60ac7789428d5056b41ca9.zip
dev-ros/rqt_topic: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild')
-rw-r--r--dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild b/dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild
new file mode 100644
index 000000000000..bf621ebec809
--- /dev/null
+++ b/dev-ros/rqt_topic/rqt_topic-0.4.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_topic"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying debug information about ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"